GeoDirectory <= 2.2.23 - Authenticated (Admin+) SQL Injection

7.2
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CVE CVE-2023-0278
CVSS 7.2 (High)
Publicly Published January 31, 2023
Last Updated February 5, 2023
Researchers Daniel Krohmer
Kunal Sharma

Description

The GeoDirectory plugin for WordPress is vulnerable to SQL Injection via the 'selected', 'post_type' parameters in versions up to, and including, 2.2.23 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for administrator-level attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

References

Share

Vulnerability Details for GeoDirectory – WordPress Business Directory Plugin, or Classified Directory

Software Type Plugin
Software Slug geodirectory (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.2.24, or a newer patched version
Affected Version
  • <= 2.2.23
Patched Version
  • 2.2.24

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation