Getwid – Gutenberg Blocks <= 1.8.3 - Authenticated(Subscriber+) Server Side Request Forgery

8.5
Server-Side Request Forgery (SSRF)
CVE CVE-2023-1895
CVSS 8.5 (High)
Publicly Published June 6, 2023
Last Updated June 22, 2023
Researcher Ramuel Gall - Wordfence

Description

The Getwid – Gutenberg Blocks plugin for WordPress is vulnerable to Server Side Request Forgery via the get_remote_content REST API endpoint in versions up to, and including, 1.8.3. This can allow authenticated attackers with subscriber-level permissions or above to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.

References

Share

1 affected software package

Software Type Plugin
Software Slug getwid (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.8.4, or a newer patched version
Affected Version
  • <= 1.8.3
Patched Version
  • 1.8.4

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation