Getwid – Gutenberg Blocks <= 1.8.3 - Improper Authorization via get_remote_templates REST endpoint

4.3
Improper Authorization
CVE CVE-2023-1910
CVSS 4.3 (Medium)
Publicly Published June 6, 2023
Last Updated June 22, 2023
Researcher Ramuel Gall - Wordfence

Description

The Getwid – Gutenberg Blocks plugin for WordPress is vulnerable to unauthorized modification of data due to an insufficient capability check on the get_remote_templates function in versions up to, and including, 1.8.3. This makes it possible for authenticated attackers with subscriber-level permissions or above to flush the remote template cache. Cached template information can also be accessed via this endpoint but these are not considered sensitive as they are publicly accessible from the developer's site.

References

Share

1 affected software package

Software Type Plugin
Software Slug getwid (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.8.4, or a newer patched version
Affected Version
  • <= 1.8.3
Patched Version
  • 1.8.4

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation