Give - Donation Plugin <= 2.33.0 - Authenticated(Give Manager+) Privilege Escalation

Improper Input Validation
CVE CVE-2023-41665
CVSS 7.2 (High)
Publicly Published August 31, 2023
Last Updated January 22, 2024
Researcher Rafie Muhammad - Patchstack


The Give - Donation Plugin plugin for WordPress is vulnerable to privilege escalation due to an insufficient capability check when updating default roles in versions up to, and including, 2.33.0. This makes it possible for authenticated attackers with Give Manager privileges to elevate their privileges to those of an administrator by setting the default role in the plugin's settings.



Vulnerability Details for GiveWP – Donation Plugin and Fundraising Platform

Software Type Plugin
Software Slug give (view on
Patched? Yes
Remediation Update to version 2.33.1, or a newer patched version
Affected Version
  • < 2.33.1
Patched Version
  • 2.33.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.