GiveWP <= 2.25.1 - Authenticated (Contributor+) Arbitrary Content Deletion

Improper Authorization
CVE CVE-2023-23672
CVSS 5.4 (Medium)
Publicly Published March 10, 2023
Last Updated March 14, 2023
Researcher Rafshanzani Suhada


The GiveWP plugin for WordPress is vulnerable to Improper Authorization in versions up to, and including, 2.25.1. This makes it possible for authenticated attackers with contributor-level permissions to delete content from a vulnerable site.



Vulnerability Details for GiveWP – Donation Plugin and Fundraising Platform

Software Type Plugin
Software Slug give (view on
Patched? Yes
Remediation Update to version 2.25.2, or a newer patched version
Affected Version
  • <= 2.25.1
Patched Version
  • 2.25.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.