GiveWP <= 2.25.1 - Authenticated (Admin+) Server-Side Request Forgery via give_get_content_by_ajax_handler

Server-Side Request Forgery (SSRF)
CVE CVE-2022-40312
CVSS 4.1 (Medium)
Publicly Published March 8, 2023
Last Updated January 22, 2024
Researcher Rafie Muhammad - Patchstack


The GiveWP plugin for WordPress is vulnerable to Server-Side Request Forgery in versions up to, and including, 2.25.1 via the 'give_get_content_by_ajax_handler'. This can allow authenticated attackers with administrator-level privileges to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.



Vulnerability Details for GiveWP – Donation Plugin and Fundraising Platform

Software Type Plugin
Software Slug give (view on
Patched? Yes
Remediation Update to version 2.25.2, or a newer patched version
Affected Version
  • <= 2.25.1
Patched Version
  • 2.25.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.