Simple Calendar <= 3.1.42 - Cross-Site Request Forgery to Transient Cache Clearing

Cross-Site Request Forgery (CSRF)
CVSS 4.3 (Medium)
Publicly Published May 11, 2023
Last Updated January 22, 2024


The Simple Calendar plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.1.42. This is due to missing nonce validation on the clear_cache() function used to clear the plugin's transients. This makes it possible for unauthenticated attackers to clear the plugin's transients for a given id, via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Simple Calendar – Google Calendar Plugin

Software Type Plugin
Software Slug google-calendar-events (view on
Patched? Yes
Remediation Update to version 3.1.43, or a newer patched version
Affected Version
  • <= 3.1.42
Patched Version
  • 3.1.43

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.