Anti-Malware Security and Brute-Force Firewall <= 4.21.96 - Unauthenticated Remote Code Execution

Improper Control of Generation of Code ('Code Injection')
CVE CVE-2024-22144
CVSS 9.0 (Critical)
Publicly Published March 12, 2024
Last Updated May 7, 2024
Researcher stealthcopter


The Anti-Malware Security and Brute-Force Firewall plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.21.96 due to weak nonce generation combined with missing authorization. This makes it possible for unauthenticated attackers to brute force a valid nonce that can be used to add malware rule and execute code on the server.



Vulnerability Details for Anti-Malware Security and Brute-Force Firewall

Software Type Plugin
Software Slug gotmls (view on
Patched? Yes
Remediation Update to version 4.23.56, or a newer patched version
Affected Version
  • <= 4.21.96
Patched Version
  • 4.23.56

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.