GP Unique ID <= 1.5.5 - Unauthenticated Form Submission Unique ID Modification

Improper Input Validation
CVE CVE-2024-0710
CVSS 5.3 (Medium)
Publicly Published April 10, 2024
Last Updated May 2, 2024
Researcher Karl Emil Nikka - Nikka Systems


The GP Unique ID plugin for WordPress is vulnerable to Unique ID Modification in all versions up to, and including, 1.5.5. This is due to insufficient input validation. This makes it possible for unauthenticated attackers to tamper with the generation of a unique ID on a form submission and replace the generated unique ID with a user-controlled one, leading to a loss of integrity in cases where the ID's uniqueness is relied upon in a security-specific context.



Vulnerability Details for GP Unique ID

Software Type Plugin
Software Slug gp-unique-id
Patched? Yes
Remediation Update to version 1.5.6, or a newer patched version
Affected Version
  • <= 1.5.5
Patched Version
  • 1.5.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.