Gravityforms <= 1.8.19 - Arbitrary File Upload

Unrestricted Upload of File with Dangerous Type
CVSS 9.8 (Critical)
Publicly Published February 26, 2015
Last Updated November 23, 2022


The Gravityforms plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation via the includes/upload.php file in versions up to, and including, 1.8.19. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected sites server which may make remote code execution possible



Vulnerability Details for Gravity Forms

Software Type Plugin
Software Slug gravityforms
Patched? Yes
Remediation Update to version 1.8.20, or a newer patched version
Affected Version
  • < 1.8.20
Patched Version
  • 1.8.20

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.