Header Footer Code Manager <= 1.1.16 - Reflected Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2022-0710
CVSS 6.1 (Medium)
Publicly Published February 18, 2022
Last Updated December 15, 2022
Researcher Ram - Wordfence


The Header Footer Code Manager plugin <= 1.1.16 for WordPress is vulnerable to Reflected Cross-Site Scripting (XSS) via the $_REQUEST['page'] parameter.



1 affected software package

Software Type Plugin
Software Slug header-footer-code-manager (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.1.17, or a newer patched version
Affected Version
  • <= 1.1.16
Patched Version
  • 1.1.17

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.