Elementor Header & Footer Builder <= 1.6.26 - Authenticated (Author+) HTML Injection

Missing Authorization
CVE CVE-2024-2619
CVSS 5.0 (Medium)
Publicly Published May 16, 2024
Last Updated May 16, 2024
Researcher wesley (wcraft)


The Elementor Header & Footer Builder for WordPress is vulnerable to HTML Injection in all versions up to, and including, 1.6.26 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author-level permissions and above, to inject arbitrary HTML in pages that will be shown whenever a user accesses an injected page.



Vulnerability Details for Elementor Header & Footer Builder

Software Type Plugin
Software Slug header-footer-elementor (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.6.27, or a newer patched version
Affected Version
  • <= 1.6.26
Patched Version
  • 1.6.27

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.