Hide My WP Ghost <= 5.0.25 - CAPTCHA Bypass in brute_math_authenticate

5.3
Reliance on Untrusted Inputs in a Security Decision
CVE CVE-2023-34001
CVSS 5.3 (Medium)
Publicly Published August 22, 2023
Last Updated August 28, 2023
Researcher konagash

Description

The Hide My WP Ghost plugin for WordPress is vulnerable to CAPTCHA Bypass in versions up to, and including, 5.0.25. This is due a logic flaw within the brute_math_authenticate function. This makes it possible for unauthenticated attackers to bypass CAPTCHA by omitting the `brute_ck` parameter from the authentication request.

References

Share

Vulnerability Details for Hide My WP Ghost – Security Plugin

Software Type Plugin
Software Slug hide-my-wp (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.0.26, or a newer patched version
Affected Version
  • <= 5.0.25
Patched Version
  • 5.0.26

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation