Highcompress Image Compressor <= 5.0.0 - Missing Authorization via multiple AJAX actions

Missing Authorization
CVE CVE-2023-40209
CVSS 6.5 (Medium)
Publicly Published August 11, 2023
Last Updated September 21, 2023
Researcher Abdi Pranata


The Highcompress Image Compressor plugin for WordPress is vulnerable to unauthorized modification of datadue to a missing capability check on the 'verify_highcompress_process_auto', 'verify_highcompress_process_images', and 'verify_highcompress_api_key' AJAX functions in versions up to, and including, 5.0.0. This makes it possible for authenticated attackers, with subscriber-level access and above, to compress images and verify or modify the plugin's API key.



1 affected software package

Software Type Plugin
Software Slug high-compress (view on wordpress.org)
Patched? Yes
Remediation Update to version 6.0.0, or a newer patched version
Affected Version
  • <= 5.0.0
Patched Version
  • 6.0.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.