Freemius SDK <= 2.4.2 - Missing Authorization Checks

6.3
Missing Authorization
CVSS 6.3 (Medium)
Publicly Published March 4, 2022
Last Updated March 14, 2024

Description

The Freemius SDK, as used by hundreds of WordPress plugin and theme developers, was vulnerable to Cross-Site Request Forgery and Information disclosure due to missing capability checks and nonce protection on the _get_debug_log, _get_db_option, and the _set_db_option functions in versions up to, and including 2.4.2. Any WordPress plugin or theme running a version of Freemius less than 2.4.3 is vulnerable.

Wordfence blocked 61 attacks targeting this vulnerability in the past 24 hours.

References

Share

Vulnerability Details for HM Multiple Roles

Software Type Plugin
Software Slug hm-multiple-roles (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.6, or a newer patched version
Affected Version
  • < 1.6
Patched Version
  • 1.6

1-20 of 619 other affected software packages

Search affected software packages

Software Type Plugin
Software Slug 3d-viewer (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.2.7, or a newer patched version
Affected Version
  • < 1.2.7
Patched Version
  • 1.2.7
Software Type Plugin
Software Slug setka-editor (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.1.17, or a newer patched version
Affected Version
  • < 2.1.17
Patched Version
  • 2.1.17
Software Type Plugin
Software Slug abeta-punchout (view on wordpress.org)
Patched? No
Remediation No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
Affected Version
  • All Versions
Software Type Plugin
Software Slug wp-stripe-donation (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.9, or a newer patched version
Affected Version
  • < 2.9
Patched Version
  • 2.9
Software Type Plugin
Software Slug acf-for-woocommerce-product (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.8, or a newer patched version
Affected Version
  • < 1.8
Patched Version
  • 1.8
Software Type Plugin
Software Slug activity-log-mainwp (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.7.1, or a newer patched version
Affected Version
  • < 1.7.1
Patched Version
  • 1.7.1
Software Type Plugin
Software Slug add-expires-headers (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.6, or a newer patched version
Affected Version
  • < 2.6
Patched Version
  • 2.6
Software Type Plugin
Software Slug lktags-linkedin-insight-tags (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.2.4, or a newer patched version
Affected Version
  • < 1.2.4
Patched Version
  • 1.2.4
Software Type Plugin
Software Slug add-pinterest-conversion-tags (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.2.3, or a newer patched version
Affected Version
  • < 1.2.3
Patched Version
  • 1.2.3
Software Type Plugin
Software Slug add-tiktok-advertising-pixel (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.2.2, or a newer patched version
Affected Version
  • < 1.2.2
Patched Version
  • 1.2.2
Software Type Plugin
Software Slug add-twitter-pixel (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.0.4, or a newer patched version
Affected Version
  • < 1.0.4
Patched Version
  • 1.0.4
Software Type Plugin
Software Slug adfoxly (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.8.5, or a newer patched version
Affected Version
  • <= 1.8.4
Patched Version
  • 1.8.5
Software Type Plugin
Software Slug app-ads-txt (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.1.7.0, or a newer patched version
Affected Version
  • < 1.1.7.0
Patched Version
  • 1.1.7.0
Software Type Plugin
Software Slug advance-menu-manager (view on wordpress.org)
Patched? No
Remediation No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
Affected Version
  • All Versions
Software Type Plugin
Software Slug advanced-classifieds-and-directory-pro (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.8.8, or a newer patched version
Affected Version
  • < 1.8.8
Patched Version
  • 1.8.8
Software Type Plugin
Software Slug acf-options-importexport (view on wordpress.org)
Patched? No
Remediation No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
Affected Version
  • All Versions
Software Type Plugin
Software Slug advanced-database-replacer (view on wordpress.org)
Patched? No
Remediation No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
Affected Version
  • All Versions
Software Type Plugin
Software Slug advanced-page-visit-counter (view on wordpress.org)
Patched? Yes
Remediation Update to version 6.0.0, or a newer patched version
Affected Version
  • < 6.0.0
Patched Version
  • 6.0.0
Software Type Plugin
Software Slug review-engine (view on wordpress.org)
Patched? No
Remediation No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
Affected Version
  • All Versions
Software Type Plugin
Software Slug advanced-form-integration (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.49.0, or a newer patched version
Affected Version
  • < 1.49.0
Patched Version
  • 1.49.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation