WP Armour Honeypot Anti Spam <= 1.5.6 -Cross-Site Request Forgery to Arbitrary Options Update

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVSS 9.6 (Critical)
Publicly Published February 8, 2021
Last Updated January 22, 2024


The Armour Honeypot Anti Spam plugin for WordPress is vulnerable to Cross-Site Request Forgery due to missing nonce validation on the wpa_save_settings() function in versions up to, and including, 1.5.6. This makes it possible for attackers to modify arbitrary site options granted they can trick an administrator into performing an action such as clicking on a link.



Vulnerability Details for WP Armour – Honeypot Anti Spam

Software Type Plugin
Software Slug honeypot (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.5.7, or a newer patched version
Affected Version
  • < 1.5.7
Patched Version
  • 1.5.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.