Houzez Login Register <= 2.6.3 - Privilege Escalation

9.8
Improper Privilege Management
CVE CVE-2023-26009
CVSS 9.8 (Critical)
Publicly Published February 23, 2023
Last Updated January 22, 2024
Researcher Dave Jong - Patchstack

Description

The Houzez Login Register plugin for WordPress is vulnerable to privilege escalation in versions up to, and including, 2.6.3. This is due to improper assignment of privileges on user registration that allows users to supply their own role via the houzez_register AJAX action. This makes it possible for unauthenticated attackers to register as administrators on vulnerable sites.

Wordfence blocked 304 attacks targeting this vulnerability in the past 24 hours.

References

Share

Vulnerability Details for houzez-login-register

Software Type Plugin
Software Slug houzez-login-register
Patched? Yes
Remediation Update to version 2.6.4, or a newer patched version
Affected Version
  • <= 2.6.3
Patched Version
  • 2.6.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation