HT Mega – Absolute Addons for Elementor <= 2.2.0 - Missing Authorization to Privilege Escalation

9.8
Missing Authorization
CVE CVE-2023-37999
CVSS 9.8 (Critical)
Publicly Published July 7, 2023
Last Updated January 22, 2024
Researcher Rafie Muhammad - Patchstack

Description

The HT Mega plugin for WordPress is vulnerable to Missing Authorization in versions up to, and including, 2.2.0. This is due to missing validation of the reg_role parameter on the htmega_ajax_register function. This makes it possible for unauthenticated attackers to create administrator accounts.

Wordfence blocked 18,316 attacks targeting this vulnerability in the past 24 hours.

References

Share

Vulnerability Details for HT Mega – Absolute Addons For Elementor

Software Type Plugin
Software Slug ht-mega-for-elementor (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.2.1, or a newer patched version
Affected Version
  • < 2.2.1
Patched Version
  • 2.2.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation