HT Mega – Absolute Addons For Elementor <= 2.4.7 - Missing Authorization to Information Exposure

Information Exposure
CVE CVE-2024-32782
CVSS 4.3 (Medium)
Publicly Published April 22, 2024
Last Updated May 2, 2024
Researcher Khalid


The HT Mega plugin for WordPress is vulnerable to unauthorized access of data due to an insufficient capability check on the duplicate() function in all versions up to, and including, 2.4.7. This makes it possible for authenticated attackers, with contributor-level access and above, to duplicate arbitrary posts that may contain sensitive information.



Vulnerability Details for HT Mega – Absolute Addons For Elementor

Software Type Plugin
Software Slug ht-mega-for-elementor (view on
Patched? Yes
Remediation Update to version 2.4.8, or a newer patched version
Affected Version
  • <= 2.4.7
Patched Version
  • 2.4.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.