HT Mega – Absolute Addons For Elementor <= 2.5.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Gallery Justify

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2024-3989
CVSS 6.4 (Medium)
Publicly Published May 7, 2024
Last Updated May 9, 2024
Researcher Ngô Thiên An (ancorn_) - VNPT-VCI


The HT Mega – Absolute Addons For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Gallery Justify Widget in all versions up to, and including, 2.5.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for HT Mega – Absolute Addons For Elementor

Software Type Plugin
Software Slug ht-mega-for-elementor (view on
Patched? Yes
Remediation Update to version 2.5.1, or a newer patched version
Affected Version
  • <= 2.5.0
Patched Version
  • 2.5.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.