HT Mega – Absolute Addons For Elementor <= 2.5.2 - Missing Authorization to Options Update

Missing Authorization
CVE CVE-2024-4875
CVSS 4.3 (Medium)
Publicly Published May 20, 2024
Last Updated May 21, 2024
Researcher 1337_Wannabe - home


The HT Mega – Absolute Addons For Elementor plugin for WordPress is vulnerable to unauthorized modification of data|loss of data due to a missing capability check on the 'ajax_dismiss' function in versions up to, and including, 2.5.2. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to update options such as users_can_register, which can lead to unauthorized user registration.



Vulnerability Details for HT Mega – Absolute Addons For Elementor

Software Type Plugin
Software Slug ht-mega-for-elementor (view on
Patched? Yes
Remediation Update to version 2.5.3, or a newer patched version
Affected Version
  • <= 2.5.2
Patched Version
  • 2.5.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.