HT Mega - Absolute Addons for Elementor Page Builder <= 1.5.5 - Contributor+ Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-24261
CVSS 5.4 (Medium)
Publicly Published April 13, 2021
Last Updated January 22, 2024
Researcher Ram - Wordfence


The “HT Mega – Absolute Addons for Elementor Page Builder” WordPress Plugin before 1.5.7 has several widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.



Vulnerability Details for HT Mega – Absolute Addons For Elementor

Software Type Plugin
Software Slug ht-mega-for-elementor (view on
Patched? Yes
Remediation Update to version 1.5.7, or a newer patched version
Affected Version
  • <= 1.5.5
Patched Version
  • 1.5.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.