Hummingbird <= 3.4.1 - Unauthenticated Path Traversal

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2023-1478
CVSS 5.3 (Medium)
Publicly Published March 20, 2023
Last Updated January 22, 2024
Researcher Karol Mazurek (AFINE)


The Hummingbird plugin for WordPress is vulnerable to Path Traversal in versions up to, and including, 3.4.1 via the page cache module, which doesn't validate file paths prior to saving them. This makes it possible for unauthenticated attackers to enumerate file directories, crash to server by sending cache files to an arbitrary location, and write cache files to arbitrary locations that may deny access to some resources.



Vulnerability Details for Hummingbird – Cache & Page Speed Optimization for Core Web Vitals | Critical CSS | Minify CSS | Defer CSS Javascript

Software Type Plugin
Software Slug hummingbird-performance (view on
Patched? Yes
Remediation Update to version 3.4.2, or a newer patched version
Affected Version
  • <= 3.4.1
Patched Version
  • 3.4.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.