Image Slider <= 1.1.121 - Cross-Site Request Forgery to Post Duplication

Cross-Site Request Forgery (CSRF)
CVE CVE-2022-2223
CVSS 5.4 (Medium)
Publicly Published May 24, 2022
Last Updated October 20, 2023
Researcher Marco Wotschka - Wordfence


The WordPress plugin Image Slider is vulnerable to Cross-Site Request Forgery in versions up to, and including 1.1.121 due to failure to properly check for the existence of a nonce in the function ewic_duplicate_slider. This make it possible for unauthenticated attackers to duplicate existing posts or pages granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Image Slider

Software Type Plugin
Software Slug image-slider-widget (view on
Patched? Yes
Remediation Update to version 1.1.123, or a newer patched version
Affected Version
  • <= 1.1.121
Patched Version
  • 1.1.123

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.