ImageMagick Engine <= 1.7.5 - Cross-Site Request Forgery to Remote Command Execution

Cross-Site Request Forgery (CSRF)
CVE CVE-2022-2441
CVSS 8.8 (High)
Publicly Published October 17, 2022
Last Updated October 20, 2023
Researcher Rasoul Jahanshahi


The ImageMagick Engine plugin for WordPress is vulnerable to remote code execution via the 'cli_path' parameter in versions up to, and including 1.7.5. This makes it possible for unauthenticated users to run arbitrary commands leading to remote command execution, granted they can trick a site administrator into performing an action such as clicking on a link. This makes it possible for an attacker to create and or modify files hosted on the server which can easily grant attackers backdoor access to the affected server.



1 affected software package

Software Type Plugin
Software Slug imagemagick-engine (view on
Patched? Yes
Remediation Update to version 1.7.6, or a newer patched version
Affected Version
  • <= 1.7.5
Patched Version
  • 1.7.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.