Import XML and RSS Feeds <= 2.1.4 - Unauthenticated Remote Code Execution

Improper Control of Generation of Code ('Code Injection')
CVE CVE-2023-4521
CVSS 9.8 (Critical)
Publicly Published August 28, 2023
Last Updated January 22, 2024
Researcher Enrico Marcolini - Dottor Marc Srl


The Import XML and RSS Feeds for WordPress is vulnerable to remote code execution in versions up to, and including, 2.1.4. This is due to the plugin vendor leaving a malicious file behind when patching CVE-2023-4300. This makes it possible for unauthenticated attackers to access the 169227090864de013cac47b.php file and achieve remote code execution.



Vulnerability Details for Import XML and RSS Feeds

Software Type Plugin
Software Slug import-xml-feed (view on
Patched? Yes
Remediation Update to version 2.1.5, or a newer patched version
Affected Version
  • <= 2.1.4
Patched Version
  • 2.1.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.