Injection Guard <= 1.2.1 - Cross-Site Request Forgery via ig_update

Cross-Site Request Forgery (CSRF)
CVSS 4.3 (Medium)
Publicly Published May 11, 2023
Last Updated May 15, 2023


The Injection Guard plugin for WordPress is vulnerable to Cross-Site Request Forgery due to a missing nonce check on the ig_update functions in versions up to, and including, 1.2.1. This makes it possible for unauthenticated attackers to make changes to IP block- and allowlists via a forged request granted they can trick an admin into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug injection-guard (view on
Patched? Yes
Remediation Update to version 1.2.2, or a newer patched version
Affected Version
  • <= 1.2.1
Patched Version
  • 1.2.2

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.