Injection Guard <= 1.2.1 - Missing Authorization to Whitelist Update

Missing Authorization
CVSS 5.3 (Medium)
Publicly Published May 10, 2023
Last Updated May 10, 2023
Researcher Darius Sveikauskas - Patchstack


The Injection Guard plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the ig_update function in versions up to, and including, 1.2.1. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to update the plugin's whitelist.



Vulnerability Details for Injection Guard

Software Type Plugin
Software Slug injection-guard (view on
Patched? Yes
Remediation Update to version 1.2.2, or a newer patched version
Affected Version
  • <= 1.2.1
Patched Version
  • 1.2.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.