WPCode <= 2.0.6 - Missing Authorization to Sensitive Key Disclosure/Update

Missing Authorization
CVE CVE-2023-0328
CVSS 5.4 (Medium)
Publicly Published February 9, 2023
Last Updated February 15, 2023
Researcher Sanjay Das


The WPCode plugin for WordPress is vulnerable to unauthorized access and modification of data due to a missing capability check on the ajax_auth_url, store_auth_key, and delete_auth functions in versions up to, and including, 2.0.6. This makes it possible for authenticated attackers with access to edit_posts, such as contributors, to retrieve and update the auth key for the WPCode library.



1 affected software package

Software Type Plugin
Software Slug insert-headers-and-footers (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.0.7, or a newer patched version
Affected Version
  • <= 2.0.6
Patched Version
  • 2.0.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.