Insert or Embed Articulate Content into WordPress < 4.29991 - Directory Traversal

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2019-15648
CVSS 6.5 (Medium)
Publicly Published July 2, 2019
Last Updated January 22, 2024
Researcher WPScanTeam - WPScan


The Insert or Embed Articulate Content into WordPress plugin for WordPress is vulnerable to Directory Traversal in versions up to, and including, 4.2999 via the rename_dir. This allows authenticated user with a role as low as subscriber to delete and rename arbitrary folders.



Vulnerability Details for Insert or Embed Articulate Content into WordPress

Software Type Plugin
Software Slug insert-or-embed-articulate-content-into-wordpress (view on
Patched? Yes
Remediation Update to version 4.29991, or a newer patched version
Affected Version
  • < 4.29991
Patched Version
  • 4.29991

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.