guzzlehttp/psr7 <= 1.84 and 2.0.0-2.1.0 - Improper Input Validation

Improper Input Validation
CVE CVE-2022-24775
CVSS 7.5 (High)
Publicly Published July 19, 2022
Last Updated January 22, 2024


guzzlehttp/psr7 is a PSR-7 HTTP message library. Versions prior to 1.8.4 and 2.1.1 are vulnerable to improper header parsing. An attacker could sneak in a new line character and pass untrusted values. The issue is patched in 1.8.4 and 2.1.1. There are currently no known workarounds. Some WordPress plugins and themes use this dependency though that doesn’t necessarily mean the plugin itself is vulnerable to exploitation.



Vulnerability Details for Insert Special Characters

Software Type Plugin
Software Slug insert-special-characters (view on
Patched? Yes
Remediation Update to version 1.0.5, or a newer patched version
Affected Version
  • <= 1.0.4
Patched Version
  • 1.0.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.