Instant CSS <= 1.1.4 - Missing Authorization via AJAX Actions

Missing Authorization
CVE CVE-2023-38483
CVSS 5.3 (Medium)
Publicly Published July 24, 2023
Last Updated July 28, 2023
Researcher Abdi Pranata


The Instant CSS plugin for WordPress is vulnerable to unauthorized access and modification of data due to missing capability checks on several functions called via AJAX actions in the ~/classes/class.instantcss_ajax.php file in versions up to, and including, 1.1.4. This makes it possible for authenticated attackers, with subscriber-level access and above, to perform a wide variety of actions such as retrieving css, theme, and minify data, along with updating the options for those. The unprotected AJAX actions present can be used to exploit a site via Cross-Site Scripting as well.



Vulnerability Details for Instant CSS

Software Type Plugin
Software Slug instant-css (view on
Patched? Yes
Remediation Update to version 1.1.5, or a newer patched version
Affected Version
  • <= 1.1.4
Patched Version
  • 1.1.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.