Bulk Posts Editing For WordPress <= 4.2.3 - Authenticated (Subscriber+) Missing Authorization

Missing Authorization
CVE CVE-2024-4199
CVSS 4.3 (Medium)
Publicly Published May 14, 2024
Last Updated May 15, 2024
Researcher Benedictus Jovan (aillesiM)


The Bulk Posts Editing For WordPress plugin for WordPress is vulnerable to unauthorized access of functionality due to a missing capability check on the plugin's AJAX actions in all versions up to, and including, 4.2.3. This makes it possible for authenticated attackers, with subscriber access and higher, to invoke their corresponding functions. This may lead to post creation and duplication, post content retrieval, post taxonomy manipulation.



Vulnerability Details for Bulk Posts Editing For WordPress

Software Type Plugin
Software Slug ithemeland-bulk-posts-editing-lite (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.2.4, or a newer patched version
Affected Version
  • <= 4.2.3
Patched Version
  • 4.2.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.