iThemes Sync <= 2.0.17 - Authentication Bypass

Incorrect User Management
CVSS 9.8 (Critical)
Publicly Published October 9, 2019
Last Updated January 26, 2023


The iThemes Sync plugin for WordPress is vulnerable to authentication bypass due to a missing validation on the secure key in versions up to, and including, 2.0.17. This makes it possible for unauthenticated attackers to add their own secure key leading to a complete compromise of the affected website.



Vulnerability Details for Solid Central – Site Management, Backups, Security, and Reporting

Software Type Plugin
Software Slug ithemes-sync (view on
Patched? Yes
Remediation Update to version 2.0.18, or a newer patched version
Affected Version
  • < 2.0.18
Patched Version
  • 2.0.18

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.