iThemes Sync <= 2.1.13 - Cross-Site Request Forgery and Missing Authorization via 'hide_authenticate_notice'

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-40001
CVSS 4.3 (Medium)
Publicly Published August 25, 2023
Last Updated January 22, 2024
Researcher Abdi Pranata


The iThemes Sync plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.1.13. This is due to missing or incorrect nonce validation on the hide_authenticate_notice function. This makes it possible for unauthenticated attackers to hide admin notices via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Authorization was also missing, which allowed subscribers to dismiss notices via AJAX request.



Vulnerability Details for Solid Central – Site Management, Backups, Security, and Reporting

Software Type Plugin
Software Slug ithemes-sync (view on
Patched? Yes
Remediation Update to version 2.1.14, or a newer patched version
Affected Version
  • < 2.1.14
Patched Version
  • 2.1.14

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.