Solid Central <= 3.0.0 - Stored Cross-Site Scripting via packages

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVSS 5.4 (Medium)
Publicly Published November 7, 2023
Last Updated November 8, 2023
Researcher Robin Wood


The Solid Central – Site Management, Backups, Security, and Reporting plugin for WordPress is vulnerable to Stored Cross-Site Scripting via via malicious package names in all versions up to and including 3.0.0 due to insufficient output escaping. This makes it possible for attackers able to compromise the packages retrieved from the iThemes API to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Note that such a compromise is considered highly unlikely.



Vulnerability Details for Solid Central – Site Management, Backups, Security, and Reporting

Software Type Plugin
Software Slug ithemes-sync (view on
Patched? Yes
Remediation Update to version 3.0.1, or a newer patched version
Affected Version
  • < 3.0.1
Patched Version
  • 3.0.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.