InfiniteWP Client <= 1.11.1 - Authenticated (Subscriber+) Sensitive Information Exposure

Information Exposure
CVE CVE-2023-2916
CVSS 7.5 (High)
Publicly Published August 14, 2023
Last Updated August 15, 2023
Researcher István Márton - Wordfence


The InfiniteWP Client plugin for WordPress is vulnerable to Sensitive Information Exposure in versions up to, and including, 1.11.1 via the 'admin_notice' function. This can allow authenticated attackers with subscriber-level permissions or above to extract sensitive data including configuration. It can only be exploited if the plugin has not been configured yet. If combined with another arbitrary plugin installation and activation vulnerability, it may be possible to connect a site to InfiniteWP which would make remote management possible and allow for elevation of privileges.



Vulnerability Details for InfiniteWP Client

Software Type Plugin
Software Slug iwp-client (view on
Patched? Yes
Remediation Update to version 1.12.1, or a newer patched version
Affected Version
  • <= 1.11.1
Patched Version
  • 1.12.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.