Jeg Elementor Kit <= 2.5.6 - Authorization Bypass

5.4
Authorization Bypass Through User-Controlled Key
CVE CVE-2022-3794
CVSS 5.4 (Medium)
Publicly Published November 4, 2022
Last Updated January 23, 2023
Researcher Ram - Wordfence

Description

The Jeg Elementor Kit plugin for WordPress is vulnerable to authorization bypass in various AJAX actions in versions up to, and including, 2.5.6. Authenticated users can use an easily available nonce value to create header templates and make additional changes to the site, as the plugin does not use capability checks for this purpose.

Wordfence blocked 7 attacks targeting this vulnerability in the past 24 hours.

References

Share

1 affected software package

Software Type Plugin
Software Slug jeg-elementor-kit (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.5.7, or a newer patched version
Affected Version
  • <= 2.5.6
Patched Version
  • 2.5.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation