Jeg Elementor Kit <= 2.5.6 - Unauthenticated Authorization Bypass

Authorization Bypass Through User-Controlled Key
CVE CVE-2022-3805
CVSS 8.6 (High)
Publicly Published November 4, 2022
Last Updated January 22, 2024
Researcher Ram - Wordfence


The Jeg Elementor Kit plugin for WordPress is vulnerable to authorization bypass in various functions used to update the plugin settings in versions up to, and including, 2.5.6. Unauthenticated users can use an easily available nonce, obtained from pages edited by the plugin, to update the MailChimp API key, global styles, 404 page settings, and enabled elements.



1 affected software package

Software Type Plugin
Software Slug jeg-elementor-kit (view on
Patched? Yes
Remediation Update to version 2.5.7, or a newer patched version
Affected Version
  • <= 2.5.6
Patched Version
  • 2.5.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.