Jeg Elementor Kit <= 2.6.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via Testimonial

Improper Neutralization of Alternate XSS Syntax
CVE CVE-2024-3162
CVSS 6.4 (Medium)
Publicly Published April 2, 2024
Last Updated April 29, 2024
Researcher wesley (wcraft)


The Jeg Elementor Kit plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Testimonial Widget Attributes in all versions up to, and including, 2.6.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor access or higher, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. CVE-2024-32721 is likely a duplicate of this issue.



Vulnerability Details for Jeg Elementor Kit

Software Type Plugin
Software Slug jeg-elementor-kit (view on
Patched? Yes
Remediation Update to version 2.6.4, or a newer patched version
Affected Version
  • <= 2.6.3
Patched Version
  • 2.6.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.