JetElements <= 2.6.10 - Authenticated (Contributor+) Remote Code Execution

Improper Control of Generation of Code ('Code Injection')
CVE CVE-2023-39157
CVSS 8.8 (High)
Publicly Published August 3, 2023
Last Updated August 3, 2023
Researcher Rafie Muhammad - Patchstack


The JetElements plugins for WordPress is vulnerable to Remote Code Execution in versions up to, and including, 2.6.10 via the render_meta() function that passes user supplied input to call_user_func_array(). This makes it possible for authenticated attackers, with contributor-level access and above, to execute code on the server.



1 affected software package

Software Type Plugin
Software Slug jet-elements
Patched? Yes
Remediation Update to version 2.6.11, or a newer patched version
Affected Version
  • <= 2.6.10
Patched Version
  • 2.6.11

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.