JetFormBuilder <= 3.0.8 - Authenticated (Author+) Privilege Escalation

Incorrect Privilege Assignment
CVE CVE-2023-37866
CVSS 8.8 (High)
Publicly Published July 10, 2023
Last Updated July 14, 2023
Researcher Rafie Muhammad - Patchstack


The JetFormBuilder plugin for WordPress is vulnerable to privilege escalation in versions up to, and including, 3.0.8. This is due to insufficient restrictions on the form builder. This makes it possible for authenticated attackers, with author-level access and above, to create forms that make it possible to register a user with administrative privileges.



1 affected software package

Software Type Plugin
Software Slug jetformbuilder (view on
Patched? Yes
Remediation Update to version 3.0.9, or a newer patched version
Affected Version
  • <= 3.0.8
Patched Version
  • 3.0.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.