Jetpack < 12.7 - Authenticated(Contributor+) Clickjacking via Iframe Injection

Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')
CVE CVE-2023-47774
CVSS 5.0 (Medium)
Publicly Published November 16, 2023
Last Updated January 22, 2024
Researcher Rafie Muhammad - Patchstack


The Jetpack – WP Security, Backup, Speed, & Growth plugin for WordPress is vulnerable to Clickjacking via iframe injection due to an unknown parameter in all versions up to and including 12.6.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor access and above, to inject iframes in pages that can be used to make users perform actions on untrusted sites.



1 affected software package

Software Type Plugin
Software Slug jetpack (view on
Patched? Yes
Remediation Update to version 12.7, or a newer patched version
Affected Version
  • < 12.7
Patched Version
  • 12.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.