Jobs for WordPress <= 2.7.5 - Reflected Cross-Site Scripting via job-search

6.1
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS)
CVE CVE-2024-2833
CVSS 6.1 (Medium)
Publicly Published April 17, 2024
Last Updated April 18, 2024
Researcher Krzysztof Zając - CERT PL

Description

The Jobs for WordPress plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘job-search’ parameter in all versions up to, and including, 2.7.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

References

Share

Vulnerability Details for Jobs for WordPress

Software Type Plugin
Software Slug job-postings (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.7.6, or a newer patched version
Affected Version
  • <= 2.7.5
Patched Version
  • 2.7.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation