My Private Site <= 3.0.14 - Improper Access Control to Sensitive Information Exposure via REST API

5.3
Improper Access Control
CVE CVE-2024-0978
CVSS 5.3 (Medium)
Publicly Published February 16, 2024
Last Updated February 20, 2024
Researcher Francesco Carlucci

Description

The My Private Site plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.0.14 via the REST API. This makes it possible for unauthenticated attackers to bypass the plugin's site privacy feature and view restricted page and post content.

References

Share

Vulnerability Details for My Private Site – One-Click Password Protection for All Your Site&#039;s Content

Software Type Plugin
Software Slug jonradio-private-site (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.1.0, or a newer patched version
Affected Version
  • <= 3.0.14
Patched Version
  • 3.1.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation