JS Help Desk <= 2.7.1 - Missing Authorization

Missing Authorization
CVE CVE-2022-46840
CVSS 6.3 (Medium)
Publicly Published January 27, 2023
Last Updated March 10, 2023
Researcher RE-ALTER


The JS Help Desk plugin for WordPress is vulnerable to authorization bypass due to a missing capability check on an unknown function in versions up to, and including, 2.7.1. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to invoke this function intended for higher-privileged users.



Vulnerability Details for JS Help Desk – The Ultimate Help Desk & Support Plugin

Software Type Plugin
Software Slug js-support-ticket (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.7.2, or a newer patched version
Affected Version
  • <= 2.7.1
Patched Version
  • 2.7.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.