JupiterX Core <= 3.3.8 - Unauthenticated Privilege Escalation

9.8
Authentication Bypass Using an Alternate Path or Channel
CVE CVE-2023-38389
CVSS 9.8 (Critical)
Publicly Published August 22, 2023
Last Updated August 25, 2023
Researcher Rafie Muhammad - Patchstack

Description

The JupiterX Core plugin for WordPress is vulnerable to privilege escalation due to insufficient validation in versions up to, and including, 3.3.8 due to insufficient controls on the facebook_log_user_in() function. This makes it possible for unauthenticated attackers to stage a site takeover. Please note that this affects both the free and premium version of the plugin.

Wordfence blocked 25 attacks targeting this vulnerability in the past 24 hours.

References

Share

Vulnerability Details for Jupiter X Core

Software Type Plugin
Software Slug jupiterx-core (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.4.3, or a newer patched version
Affected Version
  • <= 3.3.8
Patched Version
  • 3.4.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation