JustTables – WooCommerce Product Table <= 1.4.9 - Cross-Site Request Forgery via plugin_activation()

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-23803
CVSS 5.3 (Medium)
Publicly Published March 30, 2023
Last Updated January 22, 2024
Researcher István Márton - Wordfence


The JustTables – WooCommerce Product Table plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.4.9. This is due to missing or incorrect nonce validation on the plugin_activation() function. This makes it possible for unauthenticated attackers to activate arbitrary plugins, via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for JustTables – WooCommerce Product Table

Software Type Plugin
Software Slug just-tables (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.5.0, or a newer patched version
Affected Version
  • <= 1.4.9
Patched Version
  • 1.5.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.