Gutenberg Blocks by Kadence Blocks – Page Builder Features <= 3.1.26 - Authenticated(Contributor+) Server-Side Request Forgery (SSRF)

Server-Side Request Forgery (SSRF)
CVE CVE-2023-6964
CVSS 8.5 (High)
Publicly Published April 9, 2024
Last Updated April 9, 2024
Researcher Lucio Sá


The Gutenberg Blocks by Kadence Blocks – Page Builder Features plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 3.1.26 via the 'kadence_import_get_new_connection_data' AJAX action. This makes it possible for authenticated attackers, with contributor-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.



Vulnerability Details for Gutenberg Blocks with AI by Kadence WP – Page Builder Features

Software Type Plugin
Software Slug kadence-blocks (view on
Patched? Yes
Remediation Update to version 3.2.12, or a newer patched version
Affected Version
  • <= 3.1.26
Patched Version
  • 3.2.12

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.