Gutenberg Blocks by Kadence Blocks – Page Builder Features <= 3.2.36 - Authenticated (Contributor+) Stored Cross-Site Scripting via Countdown Timer

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2024-4209
CVSS 6.4 (Medium)
Publicly Published May 10, 2024
Last Updated May 11, 2024
Researcher Webbernaut


The Gutenberg Blocks with AI by Kadence WP – Page Builder Features plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the countdown timer in all versions up to, and including, 3.2.36 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for Gutenberg Blocks with AI by Kadence WP – Page Builder Features

Software Type Plugin
Software Slug kadence-blocks (view on
Patched? Yes
Remediation Update to version 3.2.37, or a newer patched version
Affected Version
  • <= 3.2.36
Patched Version
  • 3.2.37

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.